footerLogo
Wattpad is experiencing an issue
Incident Report for Wattpad
Resolved
🎉 Our database is back to normal! Thanks for your patience.
Posted Aug 16, 2018 - 02:25 EDT
Identified
🔎 Hmm, there seems to be an issue with our database, please hang tight while we restore service.
Posted Aug 16, 2018 - 00:16 EDT
This incident affected: General Wattpad Usability.