Wattpad Temporarily Unavailable
Incident Report for Wattpad
Resolved
This has now been resolved! 🎉 If you're still having any trouble accessing Wattpad, please contact our Support Team: https://support.wattpad.com/hc/en-us/requests/new
Posted Feb 22, 2021 - 12:03 EST
Investigating
You might have some trouble accessing Wattpad, we're currently working on resolving this as soon as possible! Thanks for your patience and understanding.
Posted Feb 22, 2021 - 11:48 EST
This incident affected: General Wattpad Usability.