footerLogo
Writer Analytics Degraded
Incident Report for Wattpad
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 11:34 EST
Update
We are currently investigating an issue that is affecting the analytics for February 28 and February 28th. Thank you for your patience!
Posted Mar 03, 2020 - 17:20 EST
Investigating
We are currently investigating this issue.
Posted Mar 03, 2020 - 17:16 EST
This incident affected: Writer Analytics.