footerLogo
Wattpad is experiencing an issue delivering email
Incident Report for Wattpad
Resolved
The issue has been resolved. Emails are no longer delayed and are flowing normally.
Posted Jun 05, 2017 - 16:19 EDT
Update
We're still working on the issue. Emails are still flowing, just slowly and delayed. We'll keep you posted!
Posted May 27, 2017 - 15:56 EDT
Identified
E-mail notifications are currently delayed. We're working hard to fix it. We'll keep you posted! We are very sorry for the inconvenience.
Posted May 27, 2017 - 10:11 EDT
Investigating
🔎 Strange - email notifications don't seem to be working. Hang tight while we look into it.
Posted May 27, 2017 - 06:32 EDT