Wattpad is experiencing an issue
Incident Report for Wattpad
Resolved
🎉 Wattpad should be up and running, folks! Thanks for your patience.
Posted Mar 20, 2017 - 23:27 EDT
Investigating
🔎 Hey Wattpadders! Looks like we might have an issue. Hang tight while we work it out.
Posted Mar 20, 2017 - 22:33 EDT