footerLogo
Wattpad is read-only
Incident Report for Wattpad
Resolved
Wattpad is back up! Sorry for the inconvenience.
Posted Oct 24, 2017 - 21:01 EDT
Investigating
We're investigating an infrastructure issue. As a preventative measure Wattpad is in read-only mode.
Posted Oct 24, 2017 - 18:53 EDT