footerLogo
Site-wide Outage
Incident Report for Wattpad
Resolved
This outage has been resolved. Thanks again for your patience!
Posted Jul 22, 2020 - 14:58 EDT
Investigating
Hey Wattpadders! We're currently experiencing an outage that is preventing access to Wattpad. Our team is working on resolving this as soon as possible. All updates will be posted here. Thanks for your patience while we sort this out!
Posted Jul 22, 2020 - 14:48 EDT
This incident affected: General Wattpad Usability.