footerLogo
Wattpad is experiencing an issue
Incident Report for Wattpad
Resolved
This incident has been resolved.
Posted Jul 02, 2018 - 18:22 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2018 - 17:07 EDT
Identified
🔎 We're looking into an issue that's causing Wattpad to be slow & unresponsive. We're working it out.
Posted Jul 02, 2018 - 15:12 EDT
This incident affected: General Wattpad Usability.