footerLogo
Status updates on Twitter
Incident Report for Wattpad
Resolved
This incident has been resolved.
Posted Nov 02, 2017 - 06:49 EDT
Investigating
We are currently investigating the status updates twitter integration.
Posted Nov 02, 2017 - 06:37 EDT