footerLogo
Wattpad is experiencing an issue delivering email notifications
Incident Report for Wattpad
Resolved
This incident has been resolved.
Posted Aug 30, 2018 - 21:03 EDT
Investigating
🔎 Strange - email notifications don't seem to be working. Hang tight while we look into it.
Posted Aug 30, 2018 - 14:36 EDT
This incident affected: Email Message Delivery.