footerLogo
Wattpad is experiencing an issue
Incident Report for Wattpad
Resolved
For those Wattpadders having technical trouble today, all issues have now been resolved! Welcome back and thanks for your patience.
Posted Jan 16, 2018 - 16:47 EST
Investigating
🔎 We're looking into an issue that's causing Wattpad to be intermittently slow & unresponsive. We're working it out.
Posted Jan 05, 2018 - 09:14 EST