footerLogo
Partial Outage
Incident Report for Wattpad
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 09:35 EDT
Identified
We are currently experiencing issues with connecting to Wattpad. Our team is working on resolving this as soon as possible. Thanks for your patience while we sort this out!
Posted Jul 22, 2020 - 16:39 EDT
This incident affected: General Wattpad Usability.