Story Statistics outage

Incident Report for Wattpad

Resolved

The issue with Story Stastics has been resolved!
Posted May 14, 2026 - 10:51 EDT

Identified

We have identified an issue that impacts Story Statistics- hang tight, we're working on resolving this as soon as possible. All updates will be posted here as soon as we have them
Posted May 08, 2026 - 15:46 EDT
This incident affected: Story Statistics.