Wattpad Temporarily Unavailable
Incident Report for Wattpad
Resolved
This issue is now resolved!
Posted Dec 22, 2021 - 10:22 EST
Investigating
We are currently investigating an issue that may impact your ability to access Wattpad - hang tight, we're working on resolving this as soon as possible!
Posted Dec 22, 2021 - 10:12 EST
This incident affected: General Wattpad Usability.