Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2024 - 16:00 EDT
Scheduled
Hey Wattpadders! From 4pm EST October 8 to 12pm EST October 10th, Wattpad will be undergoing maintenance which will prevent Story Statistics from updating. Thank you for your patience and understanding while we work through this.
Posted Oct 08, 2024 - 15:56 EDT
This scheduled maintenance affected: Story Statistics.