Outage
Incident Report for Wattpad
Resolved
This issue has been resolved, thank you for your patience while we worked on it! 🎉
If you’re still having trouble accessing Wattpad, please submit a ticket to our Support team here: https://support.wattpad.com/hc/en-us/requests/new
Posted Oct 14, 2022 - 12:13 EDT
Investigating
We are currently investigating an issue that may impact the usability of our website - hang tight, we're working on resolving this as soon as possible. All updates will be posted here as soon as we have them!
Posted Oct 14, 2022 - 12:03 EDT
This incident affected: General Wattpad Usability.