Wattpad Outage
Incident Report for Wattpad
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 10:50 EST
Investigating
We are currently investigating an issue that may impact the overall Wattpad performance - hang tight, we're working on resolving this as soon as possible. All updates will be posted here as soon as we have them!
Posted Feb 21, 2024 - 10:15 EST
This incident affected: General Wattpad Usability.